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Introduction 
 

In a recent GIMP related map I spent a fair amount of time trying 

to figure out the best way of making borders to frame the piece.  

I’m not at all confident that I landed upon the “best way” of 

achieving what I sought, but I did at least discover “a” way of 

getting the job done.  After posting the finished map, there was 

some interest from other GIMP users on how I made my borders.  

So I thought I’d share the techniques I used with the Guild. 

 

 

How to Use this Tutorial 

 

This tutorial is written for both the beginner and the experienced 

GIMP user.  For the beginner I have included quite a bit of 

explanatory text as well as screenshot figures illustrating the tools 

and settings that we will be using, and the progression of our 

map borders.  I have divided the tutorial into two sections; the 

first dealing with traditional borders (for parchment maps) and 

the second dealing with ornate borders (for artistic and photo-

realistic maps).  Where overlap occurs in the second section, I 

refer the reader to the explanatory details of the first section. 

 

For those of you with more experience, I’ll be highlighting the key 

commands used so that you can skip over the explanatory text 

(in this I’ve taken my cue from Tear).  Here’s an example of what 

the highlights will look like: 

 

 

 

In addition to explanatory text, figures and key commands, I’ve 

also included some “Mapping Tips” windows (just look for the  

icon) that serve to highlight information I deem important, as 

well as to offer tips and tricks I’ve learned related to GIMP and 

fantasy cartography.   

 

 

What You Will Need 

 

I will be using version 2.6.10 of GIMP for this tutorial.  In addition, I 

will be making use of a custom Script called “Layer Effects” that 

is not a part of the standard GIMP download package.  Basically 

this script attempts to emulate some of the layer styles available 

within Photoshop.  You can find this script at the GIMP Plug-in 

Registry, at this address: http://registry.gimp.org/node/186.  

Finally, I will be using a tiled pattern for the photo-realistic map 

border.  You can find an uploaded copy of this pattern on the 

tutorial page where this pdf is posted, or just use your own. 

 

 

Terminology 

 

Just a Quick note regarding terms.  Despite the name of this 

tutorial, the “border” of the map is only one element of what 

people typically think of as a map border.  Other common 

elements include neat lines, border lines, margins, and frames.  

While some variance in the usage of these terms exists, roughly 

they may be characterized as follows (See also Figure 1): 

 

A neat line is a boundary line which encloses and defines the 

geographical data of a map.  This is frequently displayed as a 

grid or graticule, but can also be a single line, a double line or a 

more complex border design.   

 

A borderline is the outermost line of a border. 

 

A border is the area of the map that includes the neat line, the 

border line(s), and all that lies between. 

 

A margin is the area of the map that is between the borderline 

and the frame. 

 

A frame (sometimes called chart border line) is the outermost 

line or border pattern surrounding the entire map. 

 

 

Figure 1: Elements of a Map Border 
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Traditional Borders 
 

 

This section shows how to create a border suitable for old style, 

parchment maps, such as the one shown in Figure 13.  For this 

demonstration I will be using a cropped section of one of my 

existing maps.  However the initial screenshots will all be in black 

and white since I will not create the parchment background until 

after I have finished resizing the canvas of the map.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Neat Lines: Checkered Patterns 

 

Alright, let’s begin.  If you haven’t already started work on a 

map, go ahead and create your new document now.  Set the 

Height and Width to the desired px size, however bear in mind 

the lessons of “Before You Begin”.  As mentioned, I’ll be using an 

image with a starting canvas size of 1080x1080px (which will then 

be expanded to 1100x1100px), but if you are working with a 

regional or world map you will probably want to use a much 

larger starting canvas size (e.g. 2080x2080px or larger), otherwise 

your map will likely end up being too small. 

 
Figure 2: Original Canvas Size 1080x1080px 
 

 
 

To create a new document in GIMP, click on the file menu and 

select “New”.  In the “Create New Image” pop-up window that 

emerges, set the Height and Width (make sure that this se to 

“pixels”).  Then, click on the “Advanced Options” drop-down 

menu and set the X and Y resolution to 300. 

 

 

 

After you have created your new document (or opened an 

existing map document), we are going to make a selection of 

the entire canvas.  To do this, click on the “Select” menu and 

select “Select all”.  You should now see “marching ants” 

surrounding the entire image.  Next we are going to save this 

selection as a path.  Click on the “Select” menu again, but this 

time select “To Path”.  The selection will now be traced along a 

path located in your Paths dialogue (which should be the third 

dialogue of your “Layers, Channels, Paths” Doc (see Figure 3): 

 
Figure 3: Layers Dialogue 

Click on the Paths dialogue.  

You should see a single path 

named “Selection” (this is the 

default name for all paths).  

Double click on this word to 

select it, then rename this 

path “Neat Line Bottom”. 

 

  Before You Begin 
Working with a checkers patterned set of neat lines can 

be tricky at first, and if one is not careful, one could easily 

make one of the following mistakes: 

 

 
 

What you want to end up with rather, is something along 

the lines of this: 

 

 
 

Achieving a set of consistent checkered neat lines with 

matching corners is a function of having the right canvas 

size to begin with.  In the first example, I used a canvas 

size that was not easily divisible (e.g. 1087x1087px), and 

set the area size of the checkered boxes at 200px each.  

This resulted in cut off (see how only about half of the 

bottom left corner is showing?).  So try to avoid a canvas 

size that is not easily divisible.   

 

In the second example I set the canvas to 1200x1200px, 

and the area size of each checkered box to 200px.  The 

result is somewhat better (at least the checkered pattern 

is consistent), but those mismatched border corners are a 

bit awkward.  So try to avoid a canvas size that is only 

easily divisible by an even number of boxes. 

 

In the final example I set the canvas to 1000x1000px, and 

the area size of each box to 200px.  This resulted in a 5x5 

checkered box pattern (rather than the 6x6 pattern of the 

previous example) that was consistent and had nice 

matching corners.  The take away lesson here is that once 

you know roughly how large you want your map to be, 

be sure to determine a canvas size conducive to an odd 

number of checkered neat lines.  Also, note that the 

starting canvas size of your map will need to be smaller 

than the canvas size of its neat lines.  In this tutorial for 

example, I’m beginning with a canvas size of 1080x1080px 

(which will then be expanded to 1100x1100px) and I’ll be 

setting the area size of each checkered box to 100px.  

This will result in a checkered neat line pattern of 11x11. 

File > New > Height (select) > Width (select) > Resolution 300 
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Saving a selection to a path allows you to later re-select the 

original area, and to paint along that selection.  We will be using 

these features momentarily.  But for now, go ahead and turn off 

the selection by going to “Select” and clicking “Select None”. 

 

 

 

Next we are going to expand the canvas size of the image.  The 

expanded area will be the space wherein we place our Neat 

Lines.  To expand the canvas size, click on the “Image” menu 

and select “Canvas Size”.  In the pop-up window that emerges, 

change the Width and the Height from 1080px to 1100px (or if 

you are working with a different scaled map, to whatever the 

equivalent would be).  Once you’ve entered the new canvas 

size you should notice that the map in the preview window is 

aligned to the top left of the new canvas size.  To center the 

image, just go ahead and click on the “Center” button and then 

simply hit the “Resize” button.   

 

 

 

You’re image should now look something like Figure 4 below: 

 
Figure 4: Base Map Resized to 1100x1100px 
 

 
 

 

OK, we are ready to apply our checkered Neat Line pattern.  I 

have found at least two effective ways of achieving this effect, 

but here’s the simpler of the two methods.  Create a new 

transparent layer above your map and name it “Neat Lines”. 

 

 

 

Before we proceed, make sure that your foreground color is set 

to black (or whatever you want your darker border color to be), 

and that your background color is set to white (or whatever you 

want your lighter color to be.  If you are not sure how to do this, 

take a look at your Toolbox Dock.  Inside the toolbox you’ll see a  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 6: Foreground / Background Tool 

 

couple of solid, sheet-like 

colors stacked on top of 

each other (see Figure 6).  

The topmost color is your 

foreground color, and the 

bottom is your background.  

Clicking on either color brings 

up a pop-up window with 

several built in options for 

changing the color.  

However, if you just want to 

change the foreground color 

to black and the background color to white, just click on the 

small foreground background reset icon just to the bottom left of 

the foreground background tool. 

 

Next, (making sure that the “Neat Lines” layer is selected) click 

on the “Filters” menu and select “Render” in the submenu select 

“Patterns” and in that submenu select “Checkerboard”.  In the 

pop-up window that appears set the size to 100px (or whatever 

size you wish) and hit “OK”. 

 

 

 

You should end up with a checkerboard pattern that looks 

similar to similar to Figure 7.  I prefer to have black border corners 

so I went to the “Colors” menu and selected “Invert”. 

 
Figure 7: Checkerboard Patterns 

 

Select > Select All > To Path (Name “Neat Line Bottom”) 

 

Select > Select None 

 

  Rectangular Maps 
If you are working with a map whose width is different 

than its height then before you attempt to rescale the 

image you will need to “unlock” the aspect ratio of the 

canvas size.  When the aspect ratio is locked, GIMP will 

preserve the original shape of the canvas so that when 

you enter in a new set of measurements into one field, 

GIMP automatically recalculates the measurement of the 

other.  This however will result in a map who’s Horizontal 

and Vertical borders are each of a different width. 

 
Figure 5: Unlocking the Aspect Ratio 
 

 
 

In order to unlock the aspect ratio, simply click on the 

“Lock” icon just to the right of the Width and Height fields.  

This will allow you to enter in new measurements for each 

field separately. 

 

 

 

Layer > New Layer > Transparent (Name “Neat Lines”) 

 

Filter > Render > Pattern > Checkerboard > Size (select) > OK 

 

Image > Canvas Size > Height (select) > Width (select) > Center > Resize 
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Figure 8: Path to Selection 

 

Obviously we don’t want the 

checkerboard to cover over 

our map so let’s go ahead 

and delete this area.  Click on your path’s dialogue and select 

the “Neatline Bottom Path”.  On the bottom of the Path’s 

dialogue you’ll see some command options.  The Pink box icon 

(See Figure 8) creates a selection from the path.  Click on this 

icon, and, making sure that the “Neat Lines” layer in our Layers 

Dialogue is selected, hit delete.  This should remove the portion 

of the checkerboard pattern obscuring our map.  

 

 

 

Now go back to the “Select” menu and hit “Select None”> 

 

 

 

Your Neat Lines should now look something like Figure 9. 

 
Figure 9: Checkered Neat Lines 
 

 
 

 

Neat Lines: Top and Bottom 

 

The neat lines are nearly finished; the last thing that remains to 

do is to add a set of inner and outer lines to them.  Next we are 

going to create another selection to path, using the “Neat Lines” 

layer as our selection.  The steps are the same as previously 

noted.  Name the new path “Neat Lines Top.” 

 

 

 

Now, with “Select All” still turned on, click on the “Paint Along 

Path” command located at the bottom of your Paths Dialogue.  

In the pop-up window that appears, under “Stroke Line” set the 

line width to 2px and then click on “Stroke”. 

 

 

 

 
Figure 10: Paint Along Path 
 

Next, we are going paint the 

inner line.  Select the “Neat 

Lines Bottom” path and 

repeat the same set of steps just outlined to add a thin line along 

the bottom of the Neat Lines.  When you are finished, go to the 

“Select” menu and “Select None”.  That’s it for the Neat Lines. 

 

 

 

 

 

 

 

 

Borderlines & Frame 

 

The final steps should flow fairly quickly since they mostly deal 

with techniques we’ve already covered.  Next we are going to 

expand the canvas size one last time.  In this map, I am going to 

expand the height and width from 1100px to 1200px. 

 

 

 

Next, create a new transparent layer above the “Neat Lines” 

layer, and name it “Borderlines & Frame”.   

 

 

 

On the “Borderline & Frame” layer, go to the “Select” menu, 

select all, and save the selection as a path, named “Frame”.  

 

 

 

Next, make sure your foreground color is set to black and then 

stroke the path at a 4px line with.   

 

 

 

Onto the Borderlines.  Now go to the “Select” menu and click on 

“Shrink”.  Make sure that “Shrink from Image Border” is selected 

and set the “Shrink Selection By” field to 30px. 

 

 

 

Next, save this selection as a path named “Borderline Top”, and 

then go ahead and stroke the path with a line width of 4px. 

 

 

 

Now shrink the selection again, this time by 10px, and save that 

selection as a path named (you guessed it) “Borderline Bottom”. 

 

 

 

Alright, I bet you know what comes next.  Go ahead and stroke 

the selection, only this time set the line width to 1px. 

 

 

 

Colors > Invert 

 

Paths > Select “Neatline Bottom Path” > Path to Selection > Delete 

 

Select > Select All > To Path (Name Path “Neat Line Top”) 

 

Select > Select None 

 

Paths > “Neat Line Top” > Paint Along Path > Line Width 2px > Stroke 

 

Paths > Paint Along Path > Select > Stroke Line > Line Width 2px 

 

Paths > “Neat Line Bottom” > Path to Selection  

 
Paths > “Neat Line Bottom” > Paint Along Path > Line Width 2px > Stroke 

 

Image > Canvas Size > Height (select) > Width (select) > Center > Resize 

 

Select > Select None 

 

Layers > New Layer > Transparent (Name “Borderline & Frame”) 

 

Select > Select All > To Path (Name “Frame”) 

 

Path > “Frame” > Paint Along Path > Line Width 4px > Stroke 

 

Select > Shrink Selection > Shrink from Image Border (On) > 30px 

 

Select > To Path (Name “Borderline Top”) > Paint Along Path > 4px 

 

Select > Shrink Selection > Shrink from Image Border (On) > 10px 

 

Select > To Path (Name “Borderline Bottom”) > Paint Along Path > 1px 
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OK, we are pretty much done with our selection at this point, so 

go ahead and click “Select None” in the “Select” menu. 

 

 

 

Now if you are happy with where things are at, you could just 

stop here.  However, for this map I decided I wanted the lines 

and checkered pattern of my frame and border to better match 

the parchment tan and brown hue of the map, so I decided to 

play around with Layer modes a bit.  Here’s a quick before and 

after look at what I came up with. 

 
Figure 11: The Progression of Our Borders 
 

 
 
Figure 12: Layer Mode & Duplicate Layer 
 

What I did here (in the last pic 

of Figure 11) was to set the 

“Layer Mode” of both the 

“Neat Lines” and the “Frame 

& Borders” layers to “Overlay” 

and then duplicate each 

layer twice (See Figure 12 for 

an illustration of these 

features).   

 

Well, that about wraps up the 

first section of this tutorial.  

You can see the finished map 

below.  In the second section 

we will build on the methods 

shown in this section to make 

an ornate border. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 13: The Final Cut 
 

 
 

 

 

 

Ornate Borders 
 

 

This section shows how to create a border suitable for artistic or 

photo-realistic maps, such as the one shown in Figure 14.  Many 

of the techniques here are the same as those discussed in the 

previous section.  Where overlap occurs I’ll offer the highlighted 

keystroke commands but not the accompanying text or figures.   

I’ll be working with the same size canvas as before. 

 
Figure 14: Original Canvas Size 1080x1080px 
 

 

Select > Select None 

 

  What, no Parchment? 
If you’ve been following along so far you may be 

wondering just how I got from the black & white image in 

Figure 9 to the brown and tan parchment image shown in 

Figure 13.  I mention briefly that I created a Parchment 

Layer but don’t explain how I did this, nor for that matter 

how I mapped my existing B&W image onto it.  There are 

two good reasons for this.   

 

First, this is not a tutorial about how to make Parchment, 

neither is it a map tutorial.  This is a tutorial about how to 

make map “borders”, and I simply use the map here for 

illustrative purposes.  

 

Second, there already exist tutorials on both of these 

topics at the Cartographer’s Guild.  In fact, for this map I 

made use of RobA’s Parchment Tutorial.  Thus, rather than 

try to recreate the wheel here, I’ll just refer you to his 

wonderful little walk-through (just do a word search for it in 

the Tutorials section of the Guild). 
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Neat Lines & Margin 

 

As before, we are going to make a set of Neat Lines for our map.  

The technique here is identical to that discussed in the previous 

section, so please refer back to it for instructions.   

 

Next we are going to expand the Map canvas by 100px.  Right 

now your map ought to look something like that of Figure 15. 

 

 

 
Figure 15: Map with Neat Lines Resized to 1200x1200px 
 

 
 

OK, here’s where things are going to diverge a bit from the first 

section.  Create a new layer named “Margin”. 

 

 

 
Figure 16: Raise and Lower Layer Commands 
 

Lower the margin layer to the 

bottom of you layers stack.  

You can raise and lower 

individual layers by using the raise and lower commands located 

at the bottom of your layers dialogue. 

 

 

 
Figure 17: Patterns Dialogue 

 

Next we are going to fill this 

layer with our Slate Pattern 

(or your own pattern of 

choice).  To do this, simply go 

to your “Patterns” dialogue, 

select the “Slate” pattern, 

and then, keeping your left 

mouse key depressed, drag 

this pattern from the dialogue 

to the image.  The layer 

should now be filled with your 

pattern. 

 

 

 
Figure 18: Layer Mode 

 

The black and white 

checkered neat lines don’t 

quite match the slate margin.  

Let’s remedy that now shall 

we.  Click back on the “Neat 

Lines” layer to select it.  Now 

set the layer mode of the “Neat Lines” layer to “Overlay” (See 

Figure 18).  Awe, now that more like it. 

 

 

 
Figure 19: Map with Slate Pattern Fill 
 

 
 

 

Ornate Frame 

 

Now we are going to create an outer frame for our map, using 

the same slate pattern as before.  Click back on the “Margin” 

layer to select it.  Now, go to the “Select” menu, hit select all and 

save the selection as a Path named “Frame Top” (instructions for 

how to do this are given in the first section). 

 

 

 

Next, shrink the selection by 28px and save the newly reduced 

selection as a path named “Frame Bottom”. 

 

 

 

 

 

Next, create a new layer above the “Neat Lines Edit” layer and 

name it “Frame”. 

 

 

 

Go to the “Select” menu and select “Invert Selection”. 

Image > Canvas Size > Height (select) > Width (select) > Center > Resize 

 

Layers > New Layer > Transparent (Name “Margin”) 

 

Layers > “Margin” > Lower Layer (To Bottom of Layers Stack) 

 

Toolbox > Bucket Fill > Pattern Fill > Slate Pattern > Fill 

 

 

Layers > “Margin” > Select > Select All > To Path (Name “Frame Top”) 

 

Select > Shrink > Shrink from Image Border (On) > 28px 

 
Select > To Path (Name “Frame Bottom”) 

 

Layers > Create New Top Layer (Name: “Frame”) 

 

Layers > “Neat Lines” > Layer Mode (Overlay) 
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Go to your “Patterns” dialogue and drag and drop the “Slate” 

pattern onto the “Frame” layer.  You won’t notice it but you’ve 

just added a thin strip of the slate pattern to the layer (the 

inverted selection insures that the pattern is only applied to the 

area above the “Frame Bottom” path selection). 

 

 

 

Create a new layer above the Frame layer named “Frame Edit”. 

 

 

 

On the “Frame Edit” layer, use the “Bucket Fill” tool to fill the 

inverted selection with black (or simply drag and drop the black 

foreground color to the layer). 

 

 

 

Next, set the Layer Mode of the “Frame Edit” Layer to “Overlay”.  

Right Click on this layer and select “Merge Down”. 

 

 

 

Next, simply turn off your selection. 

 

 

 

You should now be able to see the Frame outline, which 

appears as a darker version of the slate pattern. 

 
Figure 20: Map with Frame Outline 
 

 
 

With the “Frame” layer selected, go to the “Script-Fu” menu and 

select “Bevel and Emboss”.  This will bring up a pop-up menu 

with several different options to select from.  Use the settings 

shown in Figure 21 (Size may vary depending on map size): 

 

 

Figure 21: Frame Bevel & Emboss Settings 
 

 
 

 

Your frame should now look something like Figure 22. 

 
Figure 22: Map with Inner Bevel & Emboss Applied to Frame 
 

 

Select > Invert Selection  

 

Toolbox > Bucket Fill > Pattern Fill > Slate Pattern > Fill 

 

Layers > Create New Top Layer (Name: “Frame Edit”) 

 

Toolbox > Bucket Fill > FG Color Fill (Black) > Fill 

 

Layers > “Frame Edit” > Set Layer Mode (Overlay) > Merge Down 

 

Script-Fu > Bevel & Emboss (See Figure 21 for settings) 

 

Select > Select None 
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Next let’s add some gold borderlines to the frame.  Create a 

new layer above the Frame Highlight and Frame Shadow layers.  

Name it “Gold Border Top”. 

 

 

 

Now change your Foreground color from Black to Gold (I’m 

using HTML #887d52; you can copy and paste this into the HTML 

notation field of your “Change Foreground Color” window). 

 

 

 

Next, with the “Gold Top” selected, go to your Paths dialogue 

and click on the “Frame Top” path to select it.  Then click on the 

“Paint Along Path” Icon.  Set the line width to 4px and then click 

on “Stroke”. 

 

 

 

Now we are going to apply a Pillow Emboss layer effect to this 

top gold borderline.  Go to the “Script-Fu” menu and select 

“Bevel & Emboss”.  Use the settings shown in Figure 23. 

 

 
 

Figure 23: Gold Border Pillow Emboss Settings 
 

 
 

 

Now let’s add a black stroke around the edges of the Gold 

Borderline to help better define it.  Click on the “Gold Top” layer 

again to select it.  Now go to the “Script-Fu” menu and click on 

“Stroke”.  In the pop-up window that emerges change the Color 

to black and the Position to 100.  Hit “OK”. 

 

 
 

And now for the bottom gold borderline.  Create a new layer 

above the Gold Top Highlights and Shadows layers.  Name it 

“Gold Bottom”. 

 

 

 

Once again go to your paths dialogue and select the “Frame 

Bottom” path.  Click on the “Paint Along Path” Icon.  However 

this time only set the line width to 2px (it will end up being the 

same size as the top). 

 

 

 

Next, add a Pillow Emboss Layer effect to this bottom gold 

borderline.  Use the same settings as before (i.e. as in Figure 24). 

 

 
 

As before, now add a stroke to the Gold Bottom layer.  Go to 

“Script-Fu” and change Color to black and the position to 100. 

 

 
 

Almost finished.  The last detail to be added is a drop shadow 

effect.  In your layers stack click on the “Frame” layer, then go to 

the “Script-Fu” menu and select “Drop Shadow”.  In the pop-up 

window that appears, keep all of the default settings as is, 

except for Size and Offset Distance.  Change the Size to 15px, 

and the Offset Distance to 10px.  Now click “OK”.  The End! 

 

 
 

Figure 24: The Final Cut 
 

 

Layers > Create New Top Layer (Name: “Gold Top”) 

”) 

 

Toolbox > Change Foreground Color > HTML Notation 887d52 

”) 

 

Path > “Frame Top” > Paint Along Path > Line Width 4px > Stroke 

”) 

 

Script-Fu > Bevel & Emboss (See Figure 24 for settings) 

 

Layers > Create New Top Layer (Name: “Gold Bottom” 

”) 

 

Path > “Frame Bottom” > Paint Along Path > Line Width 2px > Stroke 

”) 

 

Script-Fu > Bevel & Emboss (See Figure 24 for settings) 

 

Layers > “Frame” > Script-Fu > Drop Shadow > Size (15px) > Offset (10px) 

 

Layers > “Gold Top” > Script-Fu > Stroke > Color (Black) > Position (100) 

 

Layer > “Gold Bottom” > Script-Fu > Stroke > Color (Black) > Position (100) 

 


